Newer posts are loading.
You are at the newest post.
Click here to check if anything new just came in.

February 13 2010

Xen subtarget in OpenWRT, yay!

OpenWRT on Xen patched, up and running

Thanx to jow and thomas h., we have now working support for Xen in OpenWRT!
see the following changesets for what is done:

So you now can choose x86 as target with Xen as subtarget.
nice. we give back to the connected funk-haeusers!


December 04 2009

xm console not working (blank)

xm console not working (blank)

on some xen domUs I recently figured that the xm console didn't come
up. so investigating the issue I found out that you gotta set the
tty in the machine's config like this:

extra       = 'xencons=tty1'

but still I get a blank screen instead of the login. solution is simple,
for systems still having an inittab (eg. debian) look for the following
line:

nano /etc/inittab

1:2345:respawn:/sbin/getty 38400 tty1

for systems which utilize upstart already (ubuntu) look for another file:

nano /etc/event.d/tty1

start on stopped rc2
start on stopped rc3
start on stopped rc4
start on stopped rc5

stop on runlevel 0
stop on runlevel 1
stop on runlevel 6

respawn
exec /sbin/getty 38400 tty1

makes the xm console work on all my machines again.

June 21 2009

OpenWrt as Xen instance

preparing the guest system

you need to put following

  1. /etc/preinit

    • add "mknod /dev/hvc0 c 229 0"
    • before "exec /sbin/init"
  2. /etc/inittab

    • add "hvc0::askfirst:/bin/ash --login"

in the domU.conf, aside the usual settings:

  • disk = ['tap:aio:/path/to/openwrt-x86-ext2.fs,xvda1,w']
  • root = '/dev/xvda1 rw'
  • extra = "console=hvc0 init=/etc/preinit"
Older posts are this way If this message doesn't go away, click anywhere on the page to continue loading posts.
Could not load more posts
Maybe Soup is currently being updated? I'll try again automatically in a few seconds...
Just a second, loading more posts...
You've reached the end.

Don't be the product, buy the product!

Schweinderl